RouteConverter Forum

Full Version: Keine Kartenanzeige
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hallo zusammen,

leider habe ich 'nen Klassiker: keine Kartenanzeige! Hab ich in älteren Versionen ab und an mal gehabt, aber jetzt ist es hartnäckig.

Meine Angaben:
Ubuntu 16.04-DT-AMD64 frisch installiert und alle verfügbaren Aktualisieren installiert.

openjdk version "1.8.0_91"
OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14)
OpenJDK 64-Bit Server VM (build 25.91-b14, mixed mode)

libwebkitgtk 3.0.0

Meldung beim Start im Terminal:

java -jar RouteConverterLinux.jar
Jul 24, 2016 2:33:30 PM slash.navigation.gui.Application invokeNativeInterfaceMethod
INFORMATION: Cannot invoke NativeInterface#runEventPump(): java.lang.reflect.InvocationTargetException
Logging to /tmp/RouteConverter.log

Im Anhang mein Log. Vielleicht hab ihr ja nen Tipp  Shy

Gruß
Michael
(24.07.2016, 14:02)wshbrRC Wrote: [ -> ]Ubuntu 16.04-DT-AMD64 frisch installiert und alle verfügbaren Aktualisieren installiert.
libwebkitgtk 3.0.0

Hallo Michael,

das ist die Version 3 der Webkit-Library. Für die Eclipse SWT-basierte Karte brauchst Version 1.

(24.07.2016, 14:02)wshbrRC Wrote: [ -> ]openjdk version "1.8.0_91"
OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14)
OpenJDK 64-Bit Server VM (build 25.91-b14, mixed mode)

Das OpenJDK unterstützt soweit ich mich erinnere, den JavaFX Webbrowser für die JavaFX-basierte Karte nicht. Das Oracle JDK soll ihn angeblich enthalten.
Hallo Christian,

danke für die schnelle Antwort.
Quote:das ist die Version 3 der Webkit-Library. Für die Eclipse SWT-basierte Karte brauchst Version 1.
Ich habe die 3er wieder runtergeschmissen (ich wollt's nur gut besser machen/wissen) und die 1er installiert. Leider gleiches Ergebnis, keine Karte.
Weiterhin habe ich nach der stable 2.19 auch den Snapshot-762 probiert - hat auch nichts gebracht.

Im ersten Beitrag hatte ich aufgrund der Meldung aus dem Terminal ein Problem bei NativeInterface#runEventPump vermutet. Und im Logfile wird eine falsche Checksum für ferranti3/N52E007.hgt gemeldet. Da bist Du bisher nicht drauf eingegangen und im Forum hatte ich auch nichts gefunden ...

Gibt's noch mehr Ideen?

Gruß
Michael
(26.07.2016, 17:56)wshbrRC Wrote: [ -> ]Im ersten Beitrag hatte ich aufgrund der Meldung aus dem Terminal ein Problem bei NativeInterface#runEventPump vermutet.

Das ist die Initialisierung der Eclipse SWT-Anbindung, die fehlschlägt. Danach ist die Eclipse SWT-basierte Karte natürlich nicht lauffähig.

(26.07.2016, 17:56)wshbrRC Wrote: [ -> ]Und im Logfile wird eine falsche Checksum für ferranti3/N52E007.hgt gemeldet. Da bist Du bisher nicht drauf eingegangen und im Forum hatte ich auch nichts gefunden ...

Das hat mit der Karte nichts zu tun.
Hab jetzt leider das gleiche Problem: keine Kartenanzeige
- neu installiertes Ubuntu 16.04.01, i386
- neu runtergeladenes RouteConverterLinux.jar
openjdk version "1.8.0_91"
 OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14)
  OpenJDK Server VM (build 25.91-b14, mixed mode)

- /usr/lib/i386-linux-gnu/libwebkitgtk-1.0.so.0
  /usr/lib/i386-linux-gnu/libwebkitgtk-1.0.so.0.22.17


Tja, was kann man da tun?
Gruß, Wolf
(04.09.2016, 15:54)worie Wrote: [ -> ]Tja, was kann man da tun?

Welche Kartenansicht hast Du unter Extras/Optionen... konfiguriert? Wenn dort Eclipse SWT steht, könntest Du auf JavaFX umstellen und es mit dem Oracle JDK versuchen.
Hallo Christian,
nützt leider nichts - ich hatte schon JavaFX eingestellt und da kommt keine Karte, bei Eclipse SWT kommt sofort ein Java-Fehler:
Failed to create chrriis.dj.nativeswing.swtimp.components.core.NativeWebBrowser [3,3150023].
Wie kann ich das Swingtime extern testen bzw. auf Vordermann bringen?
Allerdings kommt nach dem Aufruf von java -jar Route...jar auch auf der Kommandozeile sofort ein Fehler:
Sep 11, 2016 6:28:29 PM slash.navigation.gui.Application invokeNativeInterfaceMethod
INFORMATION: Cannot invoke NativeInterface#runEventPump(): java.lang.reflect.InvocationTargetException

Ich fürchte, dass die Suche nach der Problemursache bei mir dadurch erschwert wird, dass ich zugegebenermaßen keine Ahnung bzgl. Java-Anwendungen habe. WO zum Beispiel muss das jdk hininstalliert werden, damit RouteConverter das findet? Mich macht nämlich stutzig, dass "java -version" liefert '...version 1.0.8_91', dabei steht die Version 101 unter /usr/share/jdk1.8.0_101 ...
Grüße, Wolf
(11.09.2016, 17:31)worie Wrote: [ -> ]nützt leider nichts - ich hatte schon JavaFX eingestellt und da kommt keine Karte, bei Eclipse SWT kommt sofort ein Java-Fehler:
Failed to create chrriis.dj.nativeswing.swtimp.components.core.NativeWebBrowser [3,3150023].

Das deutet auf eine fehlgeschlagene Initialisierung der Eclipse SWT-basierten Karte hin.

(11.09.2016, 17:31)worie Wrote: [ -> ]Wie kann ich das Swingtime extern testen bzw. auf Vordermann bringen?
Allerdings kommt nach dem Aufruf von java -jar Route...jar auch auf der Kommandozeile sofort ein Fehler:
Sep 11, 2016 6:28:29 PM slash.navigation.gui.Application invokeNativeInterfaceMethod
INFORMATION: Cannot invoke NativeInterface#runEventPump(): java.lang.reflect.InvocationTargetException

Das heißt, das die Klassen für die Eclipse SWT-basierte Karte fehlen. Seltsam, sollte nicht zusammen mit obiger Meldung auftauchen. Hast Du da ein anderes JAR genommen?

(11.09.2016, 17:31)worie Wrote: [ -> ]Ich fürchte, dass die Suche nach der Problemursache bei mir dadurch erschwert wird, dass ich zugegebenermaßen keine Ahnung bzgl. Java-Anwendungen habe. WO zum Beispiel muss das jdk hininstalliert werden, damit RouteConverter das findet?

Das weiss ich auch nicht. Für Ubuntu gibt es hier eine nette Erklärung: https://www.digitalocean.com/community/t...untu-16-04

So wählt man da die Java-Variante:

sudo update-alternatives --config java
routeconverter


Ich habe leider noch keine Lösung für mein genanntes Problem (keine Anzeige der Karte).Nun  habe ich mal (aus Verzweiflung) RouteConverter im wine-Modus laufen lassen - auch da keine Karte zu sehen und auch da kommt die Fehlermeldung auf der Konsole:

Cannot invoke NativeInterface#runEventPump(): java.lang.reflect.InvocationTar
getException


Das ist schon merkwürdig  Sad
Hallo worie,

da ich nicht weiss, was Du gemacht hast, und Du meine Frage "Hast Du da ein anderes JAR genommen?" nicht beanwortet hast, kann ich nur Kaffeesatzleserei betreiben. Keine Ahnung, was bei Dir schief läuft.
Pages: 1 2