RouteConverter Forum

Full Version: Error launching RouteConverter 2.29 (Linux)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Christian & forum members,

launching RouteConverter v2.29 gives me the following error:

-------

$ java -jar /home/seb/Programs/RouteConverter/RouteConverterLinux_current.jar
Jul 16, 2021 7:50:22 AM slash.navigation.gui.Application$1 run
SEVERE: Application class slash.navigation.converter.gui.RouteConverterOpenSource failed to launch
java.lang.reflect.InaccessibleObjectException: Unable to make field protected java.util.ResourceBundle java.util.ResourceBundle.parent accessible: module java.base does not "opens java.util" to unnamed module @221c3fe9
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:357)
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
at java.base/java.lang.reflect.Field.checkCanSetAccessible(Field.java:177)
at java.base/java.lang.reflect.Field.setAccessible(Field.java:171)
at slash.navigation.gui.Application.setParentBundle(Application.java:115)
at slash.navigation.gui.Application.initializeBundles(Application.java:106)
at slash.navigation.gui.Application.access$100(Application.java:51)
at slash.navigation.gui.Application$1.run(Application.java:152)
at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:316)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Exception in thread "AWT-EventQueue-0" java.lang.Error: Application class slash.navigation.converter.gui.RouteConverterOpenSource failed to launch
at slash.navigation.gui.Application$1.run(Application.java:162)
at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:316)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make field protected java.util.ResourceBundle java.util.ResourceBundle.parent accessible: module java.base does not "opens java.util" to unnamed module @221c3fe9
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:357)
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
at java.base/java.lang.reflect.Field.checkCanSetAccessible(Field.java:177)
at java.base/java.lang.reflect.Field.setAccessible(Field.java:171)
at slash.navigation.gui.Application.setParentBundle(Application.java:115)
at slash.navigation.gui.Application.initializeBundles(Application.java:106)
at slash.navigation.gui.Application.access$100(Application.java:51)
at slash.navigation.gui.Application$1.run(Application.java:152)
... 13 more


------

I am using

$ java -version
openjdk version "16.0.1" 2021-04-20
OpenJDK Runtime Environment (build 16.0.1+9)
OpenJDK 64-Bit Server VM (build 16.0.1+9, mixed mode)


on Manjaro Linux v21.1.0 with Xfce-Desktop.

Any suggestions on what might be going wrong and how to fix? Thanks!

Seb
Hi Seb,

there has been a similar problem with OpenJDK14 in the German forum recently. Please try the latest 2.30 prerelease of RouteConverter for Linux: click
Java 16 doesn‘t work with the 2.29

Please downgrade to Java 11 or 14 - or switch to the latest prerelease
Thank-you for your speedy replies!
Using 2.30 prerelease with Java 16 works :-)
Fantastic!