RouteConverter Forum
RouteConverter mit bestimmter JAVA-Version starten - Printable Version

+- RouteConverter Forum (https://forum.routeconverter.com)
+-- Forum: Users (https://forum.routeconverter.com/forum-17.html)
+--- Forum: Deutsch: Diskussionen (https://forum.routeconverter.com/forum-4.html)
+--- Thread: RouteConverter mit bestimmter JAVA-Version starten (/thread-2523.html)

Pages: 1 2


RouteConverter mit bestimmter JAVA-Version starten - RobKll - 21.06.2018

Hallo, liebe RouteConverter Gemeinde!

Ich bin neu hier und auch neu im Umgang mit RouteConverter.
Ich hatte beim Starten des RouteConverters gleich ein Problem, leider hat die Suche im Forum entweder nichts gefunden oder ich habe keine spezifischen Einträge zu meinem Problem gefunden.

Ich verwende Java 1.8.0- 171 (das aktuelle Update zu Java 1.8).
Beim Starten von RC kommt die Fehlermeldung:


Code:
Java 1.8.O_171 contains a fatal bug in JavaFX on Windows. Please update to Java 8 Update 152 or Java 9 or 10.


Meine Frage ist nun: Kann ich RouteConverter mit einer bestimmten Java-Version starten? Gibt es dazu beim Starten eine Option? Ich kann leider nicht auf meine derzeit verwendete Java-Version verzichten, sondern kann nur eine Java-Version zusätzlich für RouteConverter installieren.

RobKll


RE: RouteConverter mit bestimmter JAVA-Version starten - lundefugl - 21.06.2018

(21.06.2018, 10:50)RobKll Wrote: Meine Frage ist nun: Kann ich RouteConverter mit einer bestimmten Java-Version starten? Gibt es dazu beim Starten eine Option? Ich kann leider nicht auf meine derzeit verwendete Java-Version verzichten, sondern kann nur eine Java-Version zusätzlich für RouteConverter installieren.

Hallo RobKll,

ich nehme mal an, dass du die Exe-Version vom RouteConverter verwendest. Ob man damit eine andere Java-Version benutzen kann, weiss ich nicht.
Allerdings gibt es auch noch eine Jar-Version zum downloaden. (Die Exe-Version verpackt eigentlich nur die Jar-Version für eine leichtere Nutzung für die meisten Anwender).
Für die letzte offizielle Version muß man leider den Download-Link von Hand angeben. Es ist identisch zum Link der Exe, aber unterscheidet sich in der Endung. Bei den Vorabversionen hat Christian den Link in der Webseite direkt drin.
D.h. für die offizielle Web-Version wäre es http://static.routeconverter.com/download/RouteConverterWindows.jar statt http://static.routeconverter.com/download/RouteConverterWindows.exe

Wenn du die Jar-Version verwendest, dann kannst du sie mit einer beliebigen Java-Version deiner Wahl starten.
Dazu auf der Kommandozeile folgendes eingeben (die Platzhalter einfach korrekt ersetzen): "<Pfad zu deiner Java-Version>\bin\java.exe -jar <Name des RC-Jars>"

Gruß
Thomas


RE: RouteConverter mit bestimmter JAVA-Version starten - RobKll - 21.06.2018

Super, hat geklappt. Vielen Dank

Gruß,
RobKll


RE: RouteConverter mit bestimmter JAVA-Version starten - Zeppelin - 23.06.2018

Habe 'RouteConverter 2.23.3' heute gestartet und bekam die Mitteilung das es eine neue Version 2.23.5 gibt. Nach Download und Installierung bekomme ich die gleiche Fehlermeldung wie oben gezeigt. Es gibt aber bis heute keine Version wie aktuell Java 8 Update 171, welche ich installiert habe. Der Tipp mit der JAR-Version mag ja funktionieren, aber wenn der Autor schon eine EXE anbietet sollte diese auch funktionieren. Das nur mal angemerkt.

Am nächsten Tag für die Nachwelt: Ich habe jetzt den Schritt zu Java 10 vollzogen und die aktuelle 2.23.5 läuft damit. Auch andere Tools die noch Java nutzen laufen damit. Also nur Mut. Eine ältere Version wie z.B. 152 würde ich jedenfalls nur wegen 'RouteConverter' nicht installieren. Letztlich werden mit jeder neuen Version auch Sicherheitsmängel beseitigt.

MfG


RE: RouteConverter mit bestimmter JAVA-Version starten - routeconverter - 24.06.2018

(23.06.2018, 16:35)Zeppelin Wrote: Der Tipp mit der JAR-Version mag ja funktionieren, aber wenn der Autor schon eine EXE anbietet sollte diese auch funktionieren. Das nur mal angemerkt.

Das tut sie auch, aber es gibt halt eine fatalen Bug in Oracles Java FX. Dies nur mal angemerkt.

Ich könnte den Download auch um 64 MByte vergrössern und dann wäre das Leiden mit den Java 8 Updates nach dem 152er beendet. Was meint ihr?


RE: RouteConverter mit bestimmter JAVA-Version starten - Zeppelin - 25.06.2018

(24.06.2018, 22:34)routeconverter Wrote:
(23.06.2018, 16:35)Zeppelin Wrote: Der Tipp mit der JAR-Version mag ja funktionieren, aber wenn der Autor schon eine EXE anbietet sollte diese auch funktionieren. Das nur mal angemerkt.

Das tut sie auch, aber es gibt halt eine fatalen Bug in Oracles Java FX. Dies nur mal angemerkt.

Ich könnte den Download auch um 64 MByte vergrössern und dann wäre das Leiden mit den Java 8 Updates nach dem 152er beendet. Was meint ihr?

Wie geschrieben habe ich jetzt Java 10 installiert, obwohl ich nicht weiß, was das mit den ganzen Javas auf sich hat 8/9/10. Normal wäre doch 8, die wird dann nicht mehr gepflegt, dann kommt die 9 usw.  Ansonsten denke ich, die EXE ist für PCs etc. und DSL hat auch fast jeder, da sollten 64MByte verkraftbar sein. Immer noch besser, wie auf eine alte Java-Version die evtl. Sicherheitslücken hat zurück zu gehen. Das nur nochmal dazu. 


MfG


RE: RouteConverter mit bestimmter JAVA-Version starten - pebogufi - 25.06.2018

Man kann auch das letzte gut funktionierende update 152 herunterladen und installieren, das hat den bug von 171 noch nicht drin.
http://windows10store.com/download/java-jre-8-update-152-64-bit-latest-version-full-setup/
So bin ich das Problem los geworden.

Wenn es die falsche WindowsVersion ist suchen nach
java update 8 152
Gruss Peter


RE: RouteConverter mit bestimmter JAVA-Version starten - routeconverter - 26.06.2018

Wem ein Downloadportal zu suspekt ist: ich habe die Java 8 Updates 152 für Windows hier abgelegt:
http://static.routeconverter.com/download/previous-releases/jre/


RE: RouteConverter mit bestimmter JAVA-Version starten - routeconverter - 26.06.2018

(25.06.2018, 07:42)Zeppelin Wrote: Wie geschrieben habe ich jetzt Java 10 installiert, obwohl ich nicht weiß, was das mit den ganzen Javas auf sich hat 8/9/10.

Auch Java wird weiterentwickelt. Lange Zeit herrschte da Stillstand, doch nun soll alle 6 Monate eine neue Version veröffentlicht werden. Die bekommen dafür deutlich kürzere Wartungszeiten.

(25.06.2018, 07:42)Zeppelin Wrote: Normal wäre doch 8, die wird dann nicht mehr gepflegt, dann kommt die 9 usw.

Java 8 bekommt ab Ende 2018 keine öffentlichen Updates mehr. "Normal" ist aus Oracles Sicht derzeit Java 10. Java 9 ist bereits End-of-Live und bekommt keine Updates mehr.

(25.06.2018, 07:42)Zeppelin Wrote:   Ansonsten denke ich, die EXE ist für PCs etc. und DSL hat auch fast jeder, da sollten 64MByte verkraftbar sein. Immer noch besser, wie auf eine alte Java-Version die evtl. Sicherheitslücken hat zurück zu gehen.

Leider bin ich daran gescheitert, ein .exe bereitzustellen, in dem bereits ein Java enthalten ist. Das sah erst danach aus, aber Launch4j kann das nicht und einen eigenen .exe Starter kann ich nicht programmieren. Schade.


RE: RouteConverter mit bestimmter JAVA-Version starten - Zeppelin - 28.06.2018

Danke für die Erklärung zu den Java-Versionen. Ansonsten ist das mit der aktuellen *.EXE dann ja auch nicht schlimm. Es wurde ja jetzt hinreichend geschrieben, das Java 8/152 Abhilfe schafft, oder es wohl besser ist, gleich Java 10 zu installieren. Letztlich sind in Java 10 sicher auch Sicherheitzsrelevante Sachen gegenüber der 8/152 beseitigt worden.