... the user friendly GPS tool

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't Open OziExplorer Files
I have previously been opening OziExplorer files in RouteConverter but recently after updating and uninstalling old versions of Java RouteConverter stopped loading so I updated it also. Since updating I have been unable to load OziExplorer files and the error "could not open C:\.......\........\filename.plt since its file format was not detected" is displayed. As I don't load files other than OziExplorer I don't know if other formats are undetected. Why is it so? Java is version 7 Update 21 32 bit, RouteConverter v 2.9 32 bit Windows 7 operating system. I do have GPSBabel loaded on my computer but haven't linked it as that wasn't recommended.
(20.06.2013, 12:13)Ozi Tracker Wrote: Why is it so?

It seems that the updated OziExplorer is writing files that gpsbabel 1.4.4 cannot read.

Please provide a short example file that is read by RouteConverter and one that is not - either via EMail to the support address in the FAQ or inside a ZIP archive here.
OziExplorer was last updated to v3.95 11/09/2011 and I used the old version of RouteConverter many times to view newly created OziExplorer files. The problem has only been since updating Java to v7 #21 on 17/06/2013 then RouteConverter v2.9 on 19/06/2013.
In another recent post regarding problems loading .plt files there is debate about GPS Babel. I do have GPSBabel v1.4.4 on my computer but it auto loaded into C:\Program Files (x86)\GPSBabel\ path not C:\Program Files\GPSBabel\ as the code appears to me to suggest, could this be a problem?

Attached Files
.zip   BVRP 230411.zip (Size: 2.59 KB / Downloads: 677)

I had a similar issue with an other format when I had GpsBabel installed at the PC but not adressed in RouteConverter options.
The issue was finally gone after uninstalling GpsBabel. So please try this at your PC and report the results.
Kumo Wrote:
Quote:The issue was finally gone after uninstalling GpsBabel. So please try this at your PC and report the results.

Thanks for your advise I do appreciate it but I don't want to uninstall GPSBabel unless absolutely necessary, RouteConverter and GPSBabel coexisted quite happily until this update. This is a bit of an embarassment for me as I have recommended RouteConverter to many members of a club i'm in and I don't want to tell them they need to uninstall GPS Babel. If it's for the best then OK. Does GPSBabel have a role to play with RouteConverter the link in RouteConverter suggests to me it does?
RouteConverter has a internal GPSBabel and uses its funcions unless a external GPSBabel is defined.

The symptom at my PC indicates that a problem may exist if a exteral GPSBabel is present at the PC but not defined in RouteConverter options.

You may uninstall your external GPSBabel and do some tests if RouteConverter detects your files.
Then you may re-install your external GPSBabel and do the same tests again.
Finally you may specify the path to your external GPSBabel in RouteConverter options and test again.

I can't do it here - Andoid tablet & far away from home (vacation).
(21.06.2013, 01:55)Ozi Tracker Wrote: could this be a problem?

No. I'll check for your problem at the weekend.

A test on Java site said java was insecure so I updated to V7 #25 which then tested secure but the test file still didn't open . Next I followed Kumo's advise and uninstalled GPSBabel and the test file opened. So RouteConverter was working now to get it to coexist with GPSBabel.

I tried reinstalling GPSBabel but found that the test file again would not open. I found that GPSBabel had auto installed in the "Program Files (x86)" folder so I uninstalled it again and reinstalled specifying the "Program Files" folder and success the test file opened.

Thanks Kumo and Christian for your help.
You're welcome.

Nevertheless this indicates that RouteConverter 2.9 has problems when a external GPSBabel is present at the X86 folder but no external GPSBabel is specified in RouteConverter options.
(22.06.2013, 21:09)kumo Wrote: Nevertheless this indicates that RouteConverter 2.9 has problems when a external GPSBabel is present

It took me a while to figure this out since this code worked fine for years. Actually Oracle changed the semantics of calling external programs from Java in Java 1.7.0_21 for Windows. As a consequence a GPSBabel is only working properly if its path does not contain spaces.

I've fixed this in the latest prerelease. Please test and report any problems.

Forum Jump:

Users browsing this thread: 2 Guest(s)