... the user friendly GPS tool


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Big problem with FF3
#11
Hi Christian,

Before I go further, make me sure I have a good understanding of what you'd like me to do.

I am not at all familiar with the register editing. Regarding what you stated here under,

(26.07.2009, 17:45)routeconverter Wrote:
Quote:Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\JavaSoft\Prefs\slash\navigation\converter\gui\mapview]
"debug"="false"

Have a look at the HKEY.JPG wich is attached. This is what I did. Not sure this is what should be done. Tell me whether this OK or not. In case it is "not", would you please give me detailed information.


Best regards.
Bernard


Attached Files Thumbnail(s)
   
Reply
#12
(26.07.2009, 20:46)aristide Wrote: Have a look at the HKEY.JPG wich is attached. This is what I did. Not sure this is what should be done. Tell me whether this OK or not. In case it is "not", would you please give me detailed information.

Hi Bernard,

everything is fine - except that I was wrong with "false". Please set it to "true" to for more debug output in the log and on the console.
--
Christian
Reply
#13
Hi Christian,


I can see two problems while running RouteConverter (RC) with FF3 installed:
- the Google map does not show correctly
- after a variable number of conversions and other actions, the RouteConverter task is no longer responding.


I every cases, the Google map does not show correctly. This is totally repetitive.


I decide to concentrate on a way to get the RouteConverter task to hang on in 100% of the cases.
The way I found is to launch Route converter, do nothing, and wait until the PC turns into the standby mode. At the waking up of the PC, the RouteConverter task doesn't respond. It should be aborted using the Windows task manager.


I did two tests in the same PC.
I modified the Windows register to state "debug"="true"


First of all I de-installed FF3, using Windows plus manual deletion of the files in "Programfiles" and "Application data"


I installed FF2 as favourite web browser.
I started RC in command line: "java -jar routeconverterprerelease.jar
Google map showed correctly. I did nothing.
I waited until the PC is in standby mode.
At wake up, RC was still alive. Google map showed correctly. I stopped it, using Alt+F4
I saved the "RouteConverter.log" file in the "FF2" folder.
Ctrl+Break do nothing as RC was stopped. I saved the content of the Windows console in "windows_console.txt" in the "FF2" folder.



I de-installed FF2, using Windows plus manual deletion of the files in "Application data"

I installed FF3 as favourite web browser.
I started RC in command line: "java -jar routeconverterprerelease.jar
Google map didn't show correctly. I did nothing.
I waited until the PC is in standby mode.
At wake up, I typed Alt+F4 which caused RC to hang on. RC was no longer responding. A clic on the "open file" button was no operational.
I did a Ctrl+Break and saved the content of the Windows console in "windows_console.txt" in the "FF3" folder.
I closed the windows console, which made RC to close.
I saved the "RouteConverter.log" file in the "FF3" folder.


Hope this will help.
Tomorrow I will leave for a week.


Best regards.
Bernard


Attached Files
.zip   2009_07_28_logs.zip (Size: 11.28 KB / Downloads: 614)
Reply
#14
(28.07.2009, 14:47)aristide Wrote: First of all I de-installed FF3, using Windows plus manual deletion of the files in "Programfiles" and "Application data"
I installed FF2 as favourite web browser.
[..]
I de-installed FF2, using Windows plus manual deletion of the files in "Application data"
I installed FF3 as favourite web browser.
I started RC in command line: "java -jar routeconverterprerelease.jar
[..]
Hope this will help.
Tomorrow I will leave for a week.

Hi Bernard,

thank you very much for your testing efforts.

After analyzing the log files and console output my conclusion is that the IeEmbed.exe is successfully started and the routeconverter.html is loaded.
But with FF3 installed, the notification

1248782602514 documentCompleted org.jdesktop.jdic.browser.WebBrowserEvent[source=org.jdesktop.jdic.browser.WebBrowser[canvas0,0,0,337x700]] thread Thread[AWT-EventQueue-0,6,main]

that shows up with FF2 never comes up. The loading is initiated from my code but somewhere through the JDIC Java Code, the JDIC DLL, the IeEmbed.exe process, the Internet Explorer COM-Component things get screwed up. And I don't have the slightest idea why the presence of a FF3 leads to this weird effect. The logs show frequent communication between the processes if you look at the Jtrace messages:

INFO: *** Jtrace: read data from socket: 0,3024,Ouverture de la page file:///C:/Documents%20and%20Settings/Bernar/Local%20Settings/Temp/routeconverter/routeconverter.html...</html><body></html>0,3003</html><body></html>0,3024,Ouverture de la page file:///C:/Documents%20and%20Settings/Bernar/Local%20Settings/Temp/routeconverter/routeconverter.html...</html><body></html>

I'm sorry, I don't have a clue where to search. My solution is: please try the RouteConverterSWT32.jar prerelease. It is not based on JDIC (which seems to be end of life) but on Eclipse SWT.

Does that work for you?
--
Christian
Reply
#15
(28.07.2009, 16:51)routeconverter Wrote: My solution is: please try the RouteConverterSWT32.jar prerelease. It is not based on JDIC (which seems to be end of life) but on Eclipse SWT.

I found a JDIC forum entry with another fix for the problem with FF3 and applied that fix, too. Please try the RouteConverterJDIC.exe version 1.28.16, too.

Does that work for you?
--
Christian
Reply
#16
Hi Christian,

This is superb !!

Both version works perfectly. RouteConverterPrereleaseSWT32.jar as well as RouteConverterPrerelaseJDIC.exe.

Thanks a lot. I'll wait for the release.
I'll leave in a couple of hours.

Best regards.
Bernard
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)