The following warnings occurred:
Warning [2] Undefined property: MyLanguage::$archive_pages - Line: 2 - File: printthread.php(287) : eval()'d code PHP 8.1.2-1ubuntu2.14 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/printthread.php(287) : eval()'d code 2 errorHandler->error_callback
/printthread.php 287 eval
/printthread.php 117 printthread_multipage



RouteConverter Forum
Problem nach Java Update zu 1.8.0_381 - Printable Version

+- RouteConverter Forum (https://forum.routeconverter.com)
+-- Forum: Users (https://forum.routeconverter.com/forum-17.html)
+--- Forum: Deutsch: Diskussionen (https://forum.routeconverter.com/forum-4.html)
+--- Thread: Problem nach Java Update zu 1.8.0_381 (/thread-3815.html)

Pages: 1 2


Problem nach Java Update zu 1.8.0_381 - WWAK - 09.08.2023

Habe heute an 2 Win 10 Rechnern Java auf die neueste Version geändert und an beiden Systemen sind RC Registry Einträge geändert worden (z.B. alle abgewählten Online Karten waren wieder aktiv und RC ist mit der"default" Karte geöffnet worden.
Ich bin ziemlich sicher, das dies Verhalten schon mal früher diskutiert wurde, auf Grund der "RC Performance" Probleme kann ich diesen Post leider nicht mehr finden. Habe aber, weil es mir eben früher auch schon mal passiert ist, den kompletten prefs.reg Pfad gesichert und somit das "Problem schnell reparieren können.
Gibt es einen weiteren guten Tipp (nicht updaten wäre wohl eine Option), das ein Java Update, der früher dieses Verhalten nicht gezeigt hat, wieder problemlos funktioniert.

Gruß
Wilfried


RE: Problem nach Java Update zu 1.8.0_381 - dirtbiker - 16.10.2023

Passt hier nur bedingt, aber die neue Pre Version 363 vom 14.10 lässt sich mit Java8_381 nicht öffnen.

Meldung:
This application requires a Java Runtime Environment 17

Da die vorPre und die 2.33 korrekt laufen, schließe ich einen Fehler bei mir aus.


RE: Problem nach Java Update zu 1.8.0_381 - nordlicht - 16.10.2023

https://forum.routeconverter.com/showthread.php?tid=3819&pid=21887#pid21887


RE: Problem nach Java Update zu 1.8.0_381 - dirtbiker - 17.10.2023

Es gibt aber kein Runtime Environment 17 sondern nur ein Development Kit 17.
Das ist wie der Name aber schon sagt die Entwicklungsumgebung.


RE: Problem nach Java Update zu 1.8.0_381 - nordlicht - 17.10.2023

(17.10.2023, 04:47)dirtbiker Wrote: Es gibt aber kein Runtime Environment 17 sondern nur ein Development Kit 17.
Das ist wie der Name aber schon sagt die Entwicklungsumgebung.

Das JRE war schon immer im JDK enthalten. Seit Version 9 gibt es das JRE m.W. gar nicht mehr separat von Oracle, wenn man das unbedingt allein haben will, kann man z.B. bei der Eclipse-Foundation nachsehen.


RE: Problem nach Java Update zu 1.8.0_381 - hddiesel - 21.10.2023

Hallo Wilfried,

heute wurde Java Version 8 Update 391 (Build 1.8.0_391-b13) angeboten und installiert.
Habe bis jetzt keine Probleme damit.

Gruss Karl


RE: Problem nach Java Update zu 1.8.0_381 - WWAK - 22.10.2023

Hallo Karl,
gut zu lesen,dass es bei dir beim Java Upgrade keine Problem gegeben hat.
Welche RC Version verwendest du?
Wie es scheint, hat Christian bei den neuesten Pre-Versionen jetzt umgestellt und man braucht mindestens Java 17... - kein Problem bei Win 10 64 Bit Rechnern, hier findet man schnell eine passend Java Version (20...) und die Änderung hat auch ohne Probleme geklappt.
Problem hat es mit meinem alten Notebook gegeben ( Win 10 32bit) gegeben, auf en ich nicht verzichten will. Bei Eclipse Adoptium habe ich was passendes gefunden (Ver. 17...). Nur ist es mir bis jetzt nicht gelungen, das entsprechende aktuelle Prerelease.exe zu starten. Mit einer kleinen Batch Datei klappt es, wen ich das entsprechen win *.jar starte.
Kann jemand helfen, wo zu drehen ist. Meine Versuche mit den Umgebungsvariablen waren bis jetzt nicht erfolgreich.

Viele Grüsse
 Wilfried


RE: Problem nach Java Update zu 1.8.0_381 - routeconverter - 22.10.2023

(22.10.2023, 09:53)WWAK Wrote: Wie es scheint, hat Christian bei den neuesten Pre-Versionen jetzt umgestellt und man braucht mindestens Java 17...

Das ist richtig, die 2.34er Vorabversionen brauchen mindestens Java 17 und die Google Maps-basierte ist tot - sie funktioniert nach den letzten Änderungen von Google gar nicht mehr.

(22.10.2023, 09:53)WWAK Wrote: Nur ist es mir bis jetzt nicht gelungen, das entsprechende aktuelle Prerelease.exe zu starten. Mit einer kleinen Batch Datei klappt es, wen ich das entsprechen win *.jar starte.
Kann jemand helfen, wo zu drehen ist. Meine Versuche mit den Umgebungsvariablen waren bis jetzt nicht erfolgreich.

Wahrscheinlich findet das alte Launch4j in der Prerelease Dein Java 17 nicht. Ich habe gerade eine neue Vorabversion hochgeladen, die ein passendes Java auf Deiner Machine in dieser Reihenfolge sucht:

Code:
<path>%JAVA_HOME%;%PATH%</path>

Früher ging das auch über Registry Keys, aber das haben die Autoren von Launch4j entfernt.

Adoptium JDK legt den Pfad leider mit einer Versionsnummer an - das macht es unbrauchbar:

Code:
HKEY_LOCAL_MACHINE\SOFTWARE\Eclipse Adoptium\JDK\17.0.8.101\hotspot\MSI\Path

Oracle macht es nicht besser:

Code:
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\JDK\17.0.9\JavaHome

Oder Du probierst die neueste Vorabversion RouteConverterBundle.exe, die gleich ein minimiertes JRE mitbringt.


RE: Problem nach Java Update zu 1.8.0_381 - Wilfried - 22.10.2023

Ich habe heute auch Java Version 8 Update 391 unter Win 10 22H1 installiert, aber der RouteConverter 2.34 367 bringt trotzdem "... requires Java Runtime Environment 17". Ist die oben erwähnte "neueste Vorabversion" der snapshot 367 oder gibt es da noch eine neuere?

Wo finde ich die RouteConverterBundle.exe? Auf https://www.routeconverter.de/prereleases/de sehe ich die nicht.

Viele Grüße
noch ein Wilfried (nicht derselbe wie oben Smile )


RE: Problem nach Java Update zu 1.8.0_381 - WWAK - 23.10.2023

Hallo Christian,
habe das neue Prerelease *.367 getestet und es funktioniert als *.exe sowohl mit dem Win 64 Bit als auch jetzt mit dem Win 32 Bit Rechner.[Image: smile.gif].
Kein "Umweg" mehr über einen Java Batch Aufruf mehr nötig.
Danke für den schnellen Fix.
Für das alte 32 Bit Notebook habe ich für JDK ab 17 ausser bei Eclipse Adoptium nichts passendes gefunden.
Und letztlich noch ein paar Fragen: 
Ist die RC Frage bei Optionen Allgemein "Suche nach Updates bei jedem Start" so noch hilfreich?
Gibt es jetzt irgendwo einen Hinweis zur Umstellung der Java Version auf 17. oder höher?
Und sollte, wenn es deine Zeit erlaubt, bei den FAQs nicht der Hinweis auf die API Keys gelöscht werden.

Eine gute Woche und viele Grüsse

WWAK (der andere Wilfried)