... the user friendly GPS tool


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Verschieben eines Markers funktioniert nicht
#1
Hallo Christian,

ich benutze RouteConverte u.a. dazu die NMEA Aufzeichnungen von meinen Moutain Bike Touren zu korrigieren. Seit der Version 2.8 funktioniert das Verschieben eines Markers in einem Track nicht mehr.

Nachdem ich das Log File geladen habe zoome ich auf den Anfang der Aufzeichnung und verschiebe die Karte entsprechend. Wenn ich jetzt einen Trackpunkt verschiben möchte, wird der rote Marker zwar verschoben, aber mehr passiert nicht. Wenn man anschließend per rechter Maustaste einen neuen Trackpunkt einfügt, lassen sich alle Marker wieder korrekt verschieben, und zwar solange, bis die Karte wieder manuell verschoben wird.

Falls du weitere Infos brauchst gib bitte Bescheid.

Grüße
Heiko
Reply
#2
Das mit dem 'Nicht Verschieben von Punkten' ist mir gelegentlich auch schon aufgefallen.

Ich habe den Eindruck, der Mauscursor muß sich vor dem Drücken auf die linke Maustaste erst so lange auf dem 'Bobbel' befinden, bis die Bezeichnung des Punkts in einem kleinen Feld angezeigt wird. Erst dann scheint der Punkt sozusagen 'komplett' von Google Maps an RouteConverter 'übergeben' zu sein. Und erst dann klappt auch das Verschieben des Punktes.

Bitte probiere einmal aus, ob du das bestätigen kannst.
--
Matthias
Reply
#3
Das kann ich so nicht bestätigen. Auch wenn das Feld mit der Beschreibung des Punktes angezeigt wird läßt sich der rote Marker zwar verschieben, aber es passiert nichts weiter (weder die Koordinaten werden in der rechten Liste aktualisiert, noch der blaue Trackverlauf wird aktualisiert).

Bei mir ist das ein 100%ig nachvollziehbarbes Verhalten. Wenn die Karte manuell ausgerichtet (verschoben) wird muss erst ein Trackpunkt über die rechte Maustaste eingefügt werden (Insert). Dieser eingefügte Punkt kann sofort wieder gelöscht werden. Nun funktioniert das Verschieben von Trackpunkten genau solange, bis die Karte wieder manuell verschoben wird. In der Version 2.7 war dieses Verhalten noch nicht vorhanden.

Grüße
Heiko
Reply
#4
(19.08.2012, 23:39)Heiko Wrote: Falls du weitere Infos brauchst gib bitte Bescheid.

Hallo Heiko,

danke für den Fehlerbericht. Damit habe ich das Problem nachstellen können: scheinbar überholen sich da zwei AJAX-Requests im Browser und der Request, der das Bewegen der Position übermitteln soll wird von dem Request, der das Selektieren einer Position übermitteln soll, überschrieben und kommt nicht an.

Bitte teste mal die Vorabversion, ob sie den Fehler noch zeigt und (noch wichtiger!) ob nicht neue Probleme eingezogen sind im Zusammenspiel von Operationen auf der Karte und der Positionsliste. Ich habe eine Weile herumgeklickt, doch das soll nichts heißen: ich finde meine Fehler ganz selten.
--
Christian
Reply
#5
Hallo Christian,

ich hatte gerade einen relativ langen Track mit der Vorabversion bearbeitet und ich hatte keinerlei Probleme. Das Verschieben der Marker funktioniert wieder und auch sonst bin ich auf keine neuen Probleme gestoßen.

Vielen Dank für deine erstklassige und schnelle Hilfe
Heiko
Reply
#6
(21.08.2012, 22:06)Heiko Wrote: Vielen Dank für deine erstklassige und schnelle Hilfe

Danke fürs Testen!

Für alle, die das Problem auch hatten: ich habe gerade eine neue 2.8 Release-Version mit dem Datum 21. August hochgeladen.
--
Christian
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)