... the user friendly GPS tool

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can not open iGo 8 track
Somehow I can not open this iGo 8 track in latest version of RouteConverter (tried both stable and latest releases). Any idea what is wrong?

I've tried other files - the same problem.
(03.07.2013, 18:07)LA_ Wrote: Any idea what is wrong?

GPSBabel reports an unexpected end of file:

> gpsbabel.exe -r -w -t -i igo8 -f track001.trk -o gpx -F track001.gpx
IGO8: Unexpected end of file (EOF)!

This could mean that the file is corrupt or that GPSBabel cannot interpret it since it's expecting data that doesn't exist.
Thanks for your reply.
Is there any way to extract at least some data from the file?
(04.07.2013, 18:27)LA_ Wrote: Is there any way to extract at least some data from the file?

  1. Isn't there any "native" software from iGo?
  2. Get the gpsbabel source and check with a debugger what's wrong
Looks like iGo Primo on Android uses some new/internal format, which is not supported by gpsbabel...
Once I've exported tracks with iGo Primo usage, I was able to open them in RouteConverter (didn't manage to export them before since iGo was returning the error, but once I've renamed all tracks to values like 01, 02, 03 etc., the problem was resolved and tracks were exported to gpx format).

Forum Jump:

Users browsing this thread: 1 Guest(s)