... the user friendly GPS tool


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Export von Routen
#1
Hallo zusammen,
 
seit kurzem zeichne ich meine Radstrecken mit RouteConverter. Und jetzt stoße ich auf ein Problem, für das ich keine Lösung finde. Es ist eine einfache, kurze Strecke mit wenigen, sauber gezeichneten Punkten, die über einen breiten Radweg führt und sich auch im RouteConverter ohne Schwierigkeiten zeichnen lässt. Nur wird sie in jedem anderen Programm fehlerhaft dargestellt. Vor einem bestimmten Streckenabschnitt weicht der Weg auf eine Seitenstraße ab und endet kurz darauf. Meine Navi-App rechnet ebenfalls mit BRouter und identischem Profil, das sollte eigentlich zum selben Ergebnis führen. Vielleicht liegt es am Kartenmaterial. Im RouteConverter zeichne ich auf OpenAndroMap, in anderen Programmen nutze ich immer OpenVeloMap. Und mit denselben Wegpunkten gibt es keine Probleme, wenn ich die Route direkt auf einer Karte von OpenVeloMap generiere. Auch mit dem Setzen von Zwischenpunkten kann ich das Problem nicht beheben, dann verspringt der Routenverlauf an dieser Stelle.
Versucht habe ich schon einiges, Punkte zu verschieben oder zu löschen, andere Tools als den BRouter zur Berechnung genutzt. Wenn ich das richtig sehe, kann ich die Karten von OpenVeloMap im RouteConverter nicht nutzen.
Der umgekehrte Weg beim Importieren in RouteConverter war bisher immer fehlerfrei. Ich bin überrascht, dass es jetzt Probleme beim Export von Routen gibt. Und ohne eine Lösung kann ich RouteConverter nicht länger verwenden. Dieser Abschnitt liegt direkt vor meiner Haustür, fast jede meiner Strecken führt über diesen Radweg. Die Datei habe ich angehängt und würde mich freuen, wenn mir jemand helfen kann.
 
Viele Grüße,
Frank
Reply
#2
(16.06.2019, 17:29)frank-w-valley Wrote: Meine Navi-App rechnet ebenfalls mit BRouter und identischem Profil, das sollte eigentlich zum selben Ergebnis führen. Vielleicht liegt es am Kartenmaterial.

An der Karte liegt es nicht - die dient nur der Optik. Aber an den Routinginformationen (bei BRouter die .rd5 Dateien). Sind die identisch bei RouteConverter und Deiner Navi-App?

(16.06.2019, 17:29)frank-w-valley Wrote: Im RouteConverter zeichne ich auf OpenAndroMap, in anderen Programmen nutze ich immer OpenVeloMap.

Welche anderen Programme? Worum nutzt Du nicht OpenVeloMap bei RouteConverter?

(16.06.2019, 17:29)frank-w-valley Wrote: Wenn ich das richtig sehe, kann ich die Karten von OpenVeloMap im RouteConverter nicht nutzen.

Das sollte schon gehen sofern es entweder die üblichen Kacheln sind: https://forum.routeconverter.com/thread-2733.html
oder mapsforge-Kartendateien.

(16.06.2019, 17:29)frank-w-valley Wrote: Die Datei habe ich angehängt und würde mich freuen, wenn mir jemand helfen kann.

Hier hängt keine Datei dran. Pack sie in ein ZIP, dann sollte das Hochladen gelingen.
--
Christian
Reply
#3
Hallo Christian,
 
danke, dass du mir so schnell geantwortet hast. Neben OsmAnd habe ich die Route im GPX-Viewer, in GPSies und in Basecamp hochgeladen. Der Fehler wurde in allen Programmen ähnlich dargestellt.
Die beiden Treckingprofile „trecking“ bei OsmAnd und RouteConverter habe ich eben verglichen, sie sind nicht identisch. Ich kann allerdings nicht einfach das Profil  aus OsmAnd in RouteConverter kopieren, dann erhalte ich beim Berechnen der Route eine Fehlermeldung.
Diesmal habe ich die Route als gezippte Datei angehängt. Die Ursache scheint tatsächlich an den Punkten selbst zu liegen. Eben habe ich denselben Weg noch einmal in einer neuen Datei erstellt und das Problem war behoben, dann hat OsmAnd den Weg korrekt dargestellt.
Jetzt frage ich mich natürlich trotzdem, woran es gelegen hat. Die Wegpunkte stammen ursprünglich aus einer BaseCamp-Datei, die ich importiert habe. Da gab es noch etwas, was nicht immer funktionierte, wenn ich mit diesen Punkten in RouteConverter gezeichnet habe. Einzelne Punkte ließen sich nicht umbenennen.  Zwar wurde die Eingabe akzeptiert, aber wenn ich die Positionsliste erneut geladen habe, hatten sie wieder die ursprüngliche Bezeichnung (das betrifft nicht die Datei im Anhang).
Selbst die Ursache für diese Probleme zu finden, ist nicht so einfach, wenn man nicht weiß, was da im Hintergrund geschieht und wie Routen generiert werden. Vielleicht hast du einen hilfreichen Link, um das besser zu verstehen.
 
Viele Grüße,
Frank


Attached Files
.zip   Nordbahntrasse.zip (Size: 2.82 KB / Downloads: 23)
Reply
#4
Hallo Christian,

heute habe ich mich nochmals mit meinem Problem beim Export von Routen befasst. Mir scheint, dass es mehrere Ursachen gab. Jetzt habe ich ein sauberes Ergebnis, dass in jedem anderen Programm richtig dargestellt wird. Dafür konnte ich nicht die importierten Punkte verwenden, obwohl sie sauber gesetzt waren. Ich habe neue Punkte an fast identischer Stelle erzeugt. Es hat aber erst dann funktioniert, nachdem ich auch noch die Karte gewechselt habe. Mit OpenAndroMaps ging es nicht, aber mit Mapsforge. OpenAndroMaps habe ich noch nicht getestet, da mir für diese Karte der Key fehlt.
Verwundert bin ich im Augenblick schon, dass es beim Erstellen von Routen mit RouteConverter solche Hindernisse gibt. Und hoffe gerade, dass es bei der nächsten, längeren Strecke nicht die nächste Überraschung gibt.

Viele Grüße,
Frank
Reply
#5
(18.06.2019, 10:41)frank-w-valley Wrote: Verwundert bin ich im Augenblick schon, dass es beim Erstellen von Routen mit RouteConverter solche Hindernisse gibt.

Ich auch, aber ich weiss auch gar nicht, was Du wie machst, doch ich vermute irgendwo da liegt das Problem. Die Karte hat keinen Einfluss auf das Routing. Es könnte nur sein, dass die Karte Dich dazu verleitet, Wegpunkte abseits von Straßen zu platzieren - und die Routing Engine findet dann keine Route.
--
Christian
Reply
#6
Ich kann ausschließen, dass es Punkte gibt, die nicht mittig auf Wegen oder Straßen liegen. Mit maximalem Zoom habe ich jeden Punkt einzeln kontrolliert. Und wenn er nicht mittig auf der Straße oder zu nah an Kreuzungspunkten lag, habe ich das korrigiert. Man wird das auch in der Datei sehen, die ich angehängt habe, dass hier nicht die Ursache liegt. Es beschränkt sich auch nicht auf diese eine Datei. Gerade importiere ich Punkte einer anderen Route und habe wieder dasselbe Problem.
Meine Absicht war eigentlich, eine große Zahl bereits vorhandener Strecken nochmals in RouteConverter zu bearbeiten. Aber das scheint weinig Sinn zu machen, wenn ich nicht zu einem brauchbaren Ergebnis komme, ohne alles nochmals neu zu zeichnen.
Besteht die Möglichkeit, dass das Programm selbst  fehlerhaft auf dem Rechner gespeichert wurde? Eben erst habe ich ein Projekt beendet, indem ich im Menu unter „Datei“ „Neu“ gewählt habe. Trotzdem wird mir auf der Karte immer noch die Route des bereits beendeten Projekts angezeigt.
Reply
#7
Das ist ein noch offenes Problem der OpenSource Edition: das Aktualisieren der Anzeige der Route auf der Karte scheitert manchmal
--
Christian
Reply
#8
So habe ich es mir auch erklärt. Dasselbe geschieht auch manchmal mit Wegpunkten, deren Symbol trotz Deaktivierung weiter angezeigt wird.
Was mir wirklich Schwierigkeiten macht, versuche ich nochmal genauer zu beschreiben: Ich importiere eine Route, die ich in BaseCamp gezeichnet hatte. Die gezeichneten Wegpunkte werden wie in BaseCamp in der Liste aufgeführt. Sichere ich sie dann im RouteConverter, wird die Route auch in jedem anderen Programm korrekt dargestellt.
Die Wegpunkte aus BaseCamp liegen allerdings nicht genau auf dem Weg. Da fehlt ein geeigneter Zoomfaktor, um sie präzise zu setzen. Verbessere ich das im RouteConverter und verschiebe die Punkte an die richtige Stelle, dann wird es zwar im RouteConverter sauber abgebildet, aber beim erneuten Öffnen in einem anderen Programm ist die Route defekt.
Hierzu habe ich einen Screenshots angehängt. Unten auf dem Bild sieht man das Problem. In diesem Bereich habe ich nicht nur die Position korrigiert, sondern auch Punkte ersetzt und neue Punkte aus einer zweiten Liste in diese hineinkopiert. Auch hier könnte die Ursache liegen. Jetzt springt die Route am Startpunkt ins Nichts, findet einen Weg zurück und führt erst dann über die richtige Strecke. Bei GPSies sieht das anders aus, aber fehlerhaft ist es ebenfalls.
Und das beschränkt sich nicht nur auf diese Datei. Ich habe das mit jeder neuen Route, die ich im RouteConverter bearbeiten will.
Reply
#9
Da scheint wieder der Anhang zu fehlen, warum auch immer...


Attached Files Thumbnail(s)
   
Reply
#10
Hallo Frank,

das Problem heißt Basecamp. Ich habe mich inzwischen wegen des Zumo meiner LAG mehrmals damit beschäftigen müssen, was da an GPX-Dateien rauskommt, ist zwar formal valide, aber inhaltlich chaotisch und außerhalb des Garmin-Universums unbrauchbar. Plane von Anfang an mit RC, dann gibt's keine Probleme.
Grüße
Hans

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)