... the user friendly GPS tool


Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit der Karte unter Linux
#1
Hallo !

Jetzt vor Beginn der Motorradsaison wollte ihc mal wieder 'routeconverter' benutzen und siehe da: keine Kartendarstellung ! Alles andere funktioniert

System: gentoo 64-bit
Java: dev-java/sun-jre-bin-1.6.0.31
Webkit: net-libs/webkit-gtk-1.6.1-r301

Laut Routeconverter.log wille er auch Webkit benutzen:

INFO: Using WebKit runtime to create WebBrowser

Aber es funktioniert nicht
Ich versuche mal, das log-File anzuhaengen

Schoene Gruesse Malte
Reply
#2
(09.04.2012, 17:08)durandel Wrote: Ich versuche mal, das log-File anzuhaengen

Mach das mal, so kann ich dazu nichts sagen.
--
Christian
Reply
#3
Also gut, jetzt mal mit Anhang
In dem jpeg ist der Bildschirmdump beim Start

Gruss Malte


Attached Files Thumbnail(s)
   

.zip   Routeconverter.zip (Size: 1.21 KB / Downloads: 379)
Reply
#4
(10.04.2012, 16:55)durandel Wrote: Also gut, jetzt mal mit Anhang
In dem jpeg ist der Bildschirmdump beim Start

"No more handles" ist nicht richtig aussagekräftig. Da haben sie wohl mal wieder die Schnittstellen geändert, auf denen Eclipse SWT aufsetzt. Unter Linux passiert das ständig.

Probier mal die Vorabversion aus, da steckt ein neueres Eclipse SWT drin.
--
Christian
Reply
#5
Vorabversion tut leider auch nicht, log-File haengt darn

Schoene Gruesse

Malte


Attached Files
.zip   Routeconverter.zip (Size: 1.21 KB / Downloads: 374)
Reply
#6
Hallo Malte,

laut Log hast Du gerade eben nicht die Vorabversion gestartet:

Apr 14, 2012 6:05:19 PM slash.navigation.converter.gui.RouteConverter startup
INFO: Started RouteConverter 2.6 from February 25, 2012 for Linux (64-bit) with locale en_US on Java 1.6.0_31 (64-bit) and Linux 3.2.1-gentoo-r2 amd64 with 1816 MByte heap
--
Christian
Reply
#7
Hallo,

ja, stimmt aber auch mit dem pre-Release will er nicht
Kann ich auf XUL-Runner 'umschalten' oder braucht er beides ?

log-File wieder dabei ...

Schoene Gruesse

Malte


Attached Files
.zip   RouteConverter.zip (Size: 1.18 KB / Downloads: 346)
Reply
#8
(17.04.2012, 17:38)durandel Wrote: ja, stimmt aber auch mit dem pre-Release will er nicht

Ich sehe den SWT-Fehler nicht mehr im Log, dafür eine Meldung, daß eine HTML-Datei geladen wird. Was heißt "er will nicht"?

(17.04.2012, 17:38)durandel Wrote: Kann ich auf XUL-Runner 'umschalten' oder braucht er beides ?

Es wird immer noch zuerst nach WebKit verlangt, wenn es dabei Fehler gibt, wird XUL-Runner versucht:


Code:
if (isLinux()) {
                try {
                    System.setProperty("org.eclipse.swt.browser.UseWebKitGTK", "true");
                    browser = new JWebBrowser(useWebkitRuntime());
                    log.info("Using WebKit runtime to create WebBrowser");
                } catch (IllegalStateException e) {
                    System.clearProperty("org.eclipse.swt.browser.UseWebKitGTK");
                    browser = new JWebBrowser(useXULRunnerRuntime());
                    log.info("Using XULRunner runtime to create WebBrowser: " + e.getMessage());
                }
--
Christian
Reply
#9
Hallo,

na ja, er stellt die Karte nicht dar: jpeg mit dem screenshot im Anhang, aber richtig neu ist das nicht ..

Die Datei '/tmp/routeconverter-netman/routeconverter_us.html' ist vorhanden,
wenn ich versuche, sie mit firefox darzustellen kriege ich einen Tab 'RouteConverterMapView' der aber auch nur eine graue Flaeche darstellt ...

Ich weiss nicht b es was bringt, aber ich habe das html-File in den Anhang gepackt

Schoene Gruesse

Malte


Attached Files Thumbnail(s)
   

.html   routeconverter_us.html (Size: 22.47 KB / Downloads: 449)
Reply
#10
(20.04.2012, 08:48)durandel Wrote: na ja, er stellt die Karte nicht dar: jpeg mit dem screenshot im Anhang, aber richtig neu ist das nicht ..

Hat RouteConverter jemals funktioniert auf Deinem Rechner?

(20.04.2012, 08:48)durandel Wrote: Ich weiss nicht b es was bringt, aber ich habe das html-File in den Anhang gepackt

Das bringt nichts. Die HTML-Datei wird dem WebKit-Browser noch nicht einmal vorgeworfen, da die Initialisierung schon scheitert mit dem Fehler, den ich noch nie gesehen habe. Welche WebKit-Version(en) hast Du bei Dir installiert?
--
Christian
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)