... the user friendly GPS tool


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vorabversion 2.16 - Thread zum Melden von Problemen
#21
(23.08.2015, 17:43)lundefugl Wrote: das mit dem Git reaktivieren hat leider nicht geklappt. Habe jetzt über 2 Stunden damit herumprobiert.

Irgendwie meint er irgendwelche Konflikte zu haben, die er nicht lösen kann. Eigentlich kann das nicht sein, da es mein Referenz-Branch ist, auf dem ich nichts verändert habe. IntelliJ meint auch, dass dort nichts geändert wurde... :-(

Wie hast Du dein lokales git-Repo denn aufgesetzt? Ich nehme an, 2 remotes für mein und Dein github-Repo und dann wenigstens 2 master as tracking branch für die master in meinem und Deinem Repo?

Hast Du vielleicht mal mit rebase die History kaputt gemacht? Dann ist es vielleicht besser, einfach Dein/mein Repo neu zu klonen, remote und branches wieder anzulegen und fertig.

(23.08.2015, 17:43)lundefugl Wrote: @Christian: kannst du evtl. eine Version mit Logausgaben an den entscheidenden Stellen machen, die ich einfach starten kann ? Ich könnte dann die Logs hier posten.

Das hilft nichts - ich weiß ja nicht, wo die Probleme liegen. Aber die gute Nachricht ist: inzwischen konnte ich das bei mir ein paar Mal reproduzieren. Es war ein Timing-Problem und nach 5-6 Versuchen, es zu fixen, habe ich glaube ich jetzt eine Version auf dem Master/in der Vorabversion, die das Problem nicht mehr zeigt.
--
Christian
Reply
#22
Hallo Christian,

(24.08.2015, 08:56)routeconverter Wrote: Hast Du vielleicht mal mit rebase die History kaputt gemacht? Dann ist es vielleicht besser, einfach Dein/mein Repo neu zu klonen, remote und branches wieder anzulegen und fertig.

das klingt bei dir so einfach. für einen SVN-User, der nur selten sich mit Git auseinandersetzen muss, ist das schon eine kleine Herausforderung.
Aber da du das Problem ja selbst gefunden hast, kann ich mir ja Zeit lassen. Und wir haben ja bald Herbst, wo ich hoffentlich mal wieder etwas mehr Zeit finden werde.

(24.08.2015, 08:56)routeconverter Wrote: Aber die gute Nachricht ist: inzwischen konnte ich das bei mir ein paar Mal reproduzieren. Es war ein Timing-Problem und nach 5-6 Versuchen, es zu fixen, habe ich glaube ich jetzt eine Version auf dem Master/in der Vorabversion, die das Problem nicht mehr zeigt.

Das kann ich bestätigen. Bei mir funktioniert es jetzt.

Gruß Thomas
Reply
#23
(25.08.2015, 19:32)lundefugl Wrote: das klingt bei dir so einfach. für einen SVN-User, der nur selten sich mit Git auseinandersetzen muss, ist das schon eine kleine Herausforderung.

Das glaube ich. Für mich ist das seit Jahren täglich Brot.

(25.08.2015, 19:32)lundefugl Wrote: Aber da du das Problem ja selbst gefunden hast, kann ich mir ja Zeit lassen. Und wir haben ja bald Herbst, wo ich hoffentlich mal wieder etwas mehr Zeit finden werde.

Vielleicht kann ich Dir ja helfen.

(25.08.2015, 19:32)lundefugl Wrote: Das kann ich bestätigen. Bei mir funktioniert es jetzt.

Big Grin
--
Christian
Reply
#24
Hallo Christian,

(26.08.2015, 12:50)routeconverter Wrote: Vielleicht kann ich Dir ja helfen.

vielen Dank für das Angebot. Wenn ich es nicht hin bekomme, dann werde ich mich hier melden. Wie schon geschrieben, wird das noch etwas dauern. Zeit ist etwas, was ich faktisch nicht mehr habe.

Ich habe allerdings noch etwas, was in diesen Thread passt.
Ich habe die aktuelle Online-Vorabversion und dabei folgenden Effekt bemerkt.

Ist die JavaFX-Variante aktiv, so wird die Track-Linie beim scrollen nicht automatisch aktualisiert. D.h. sie bricht einfach ab.
Ist die Karte im SWT-Modus, dann klappt der Retrigger für die Aktualisierung (den hatten wir mal vor einiger Zeit eingebaut). Jedenfalls habe ich beim Nachverfolgen der Aufzeichnung (bei hohem Zoomlevel) keine Abbrüche mehr gehabt.

Gruß
Thomas
Reply
#25
(26.08.2015, 18:58)lundefugl Wrote: Ist die JavaFX-Variante aktiv, so wird die Track-Linie beim scrollen nicht automatisch aktualisiert. D.h. sie bricht einfach ab.
Ist die Karte im SWT-Modus, dann klappt der Retrigger für die Aktualisierung

Hallo Thomas,

das kann ich hier nicht reproduzieren (was meistens ohne gutes Beispiel wenig heißt) doch es klingt auch wenig plausibel: die JavaFX- und die Eclipse SWT-Karte unterscheiden sich kaum - und vor allen nicht in diesen Algorithmen. Hast Du ein Beispiel, das ich reproduzieren kann?
--
Christian
Reply
#26
Hallo Christian,

(27.08.2015, 22:00)routeconverter Wrote: das kann ich hier nicht reproduzieren (was meistens ohne gutes Beispiel wenig heißt) doch es klingt auch wenig plausibel: die JavaFX- und die Eclipse SWT-Karte unterscheiden sich kaum - und vor allen nicht in diesen Algorithmen. Hast Du ein Beispiel, das ich reproduzieren kann?

das kann ich auch nur schwer beschreiben.
Ich habe hier eine Tagesaufzeichnung von meinem Logger (über 450 km), die ich im RC lade. Anschliessend gehe ich in einen mittleren bis hohen Zoomlevel (auf einem 30" Monitor) und verfolge die Aufzeichnung (um Fehlerpunkte zu finden und dann meist zu löschen). Dabei verschiebe ich ständig den Anzeigebereich. Google kommt dabei auch teilweise kaum mit aktualisieren hinterher.
Nach einigen Verschiebeaktionen bricht bei der FX-Karte die Linie plötzlich ab. Man muss dann den Zoomlevel ändern, damit es einen Refresh gibt.

Ich habe allerdings das subjektive Gefühl, dass die JavaFX-Karte etwas langsamer ist, als die SWT-Karte. Evtl. hängt das damit zusammen. Solange ich keine Aufzeichnungsfehler sehe, verschiebe ich natürlich recht schnell hintereinander.

Gruß
Thomas
Reply
#27
Ich habe es auch immer noch, wenn ich Tracks selbst Punkt für Punkt erstelle,

dass die Linien zwischen den Punkten nicht immer stimmig mit der Reihenfolge sind. Beispiel: Track aus 4 Punkten
Reihenfolge in der Positionsliste 1,2,3,4

Die Linie geht aber von 1 nach 3, dann nach 2 und dann nach 4.
Das verwirrt und kommt während des Erstellens eigentlich regelmässig immer wieder vor.
Ist nur ne Unschönheit, aber ich kann das jedesmal reproduzieren, wenn ich mir mal wieder einen neuen Track bastle.

Gehen tut es um die Offline Version Windows 2.16.2 vom 8.09.
Reply
#28
(14.09.2015, 14:08)fboedecker Wrote: dass die Linien zwischen den Punkten nicht immer stimmig mit der Reihenfolge sind. Beispiel: Track aus 4 Punkten
Reihenfolge in der Positionsliste 1,2,3,4
Die Linie geht aber von 1 nach 3, dann nach 2 und dann nach 4.

Hallo fboedecker,

danke für den Hinweis. Leider bin ich nicht in der Lage das Nachzuvollziehen: habe diverse Male neue Tracks mit 4 Punkten erzeugt, auf der Karte per "Neu", auch per "+" und per Position/Neu

Ich habe dabei keine Inkonsistenzen gesehen. Wie erzeugst Du die?
--
Christian
Reply
#29
Ich habe doch etwas gefunden: wenn man in der Positionsliste Positionen per Drag-and-drop umhergeschoben hat oder in der Liste Positionen über die Tastatur modifiziert hat, dann wurde die Karte nicht aktualisiert. Und die markierten Positionen auf der Karte wurde nicht angepaßt.

Beides ist in der Vorabversion, die ich gerade hochgeladen habe, behoben. Bitte testet und berichtet!
--
Christian
Reply
#30
Nun, ich wähle als Typ "Track" aus. Gehe an eine Stelle im Bildschirm und wähle im Context Menu "neu".
Das wiederhole ich. Die gesetzten Punkte werden durch eine Linie verbunden.
Zeitweise aber eben so wie geschildert. Die Linie geht von 2 nach 4 und von 4 nach 3.
der Track in der Positionsliste ist aber korrekt und wenn man in der Positionsliste wandert, spüringt er auch von 2 nach 3 und von 3 nach 4.

Alles in einer ziemlich hohen Zoomstufe, damit man den Weg, auf dem der Punkt sein soll (z.B. Radweg) auch wirklich trifft. Karte Andromaps Nordrhein Westfalen
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)